migrate to jam-my-stack npm

master
Wouter Groeneveld 2 years ago
parent ca0186158c
commit a6246cf201

7
.gitignore vendored

@ -22,3 +22,10 @@ content/boek/src/synopsis.pdf
*.idx
*.ind
*.toc
.yarn/*
!.yarn/patches
!.yarn/plugins
!.yarn/releases
!.yarn/sdks
!.yarn/versions

File diff suppressed because one or more lines are too long

@ -0,0 +1,2 @@
yarnPath: ".yarn/releases/yarn-berry.cjs"
nodeLinker: node-modules

@ -0,0 +1,16 @@
const { lunr } = require('jam-my-stack');
const fsp = require('fs').promises;
(async function() {
// 1. build Lunr index
console.log("1. Building lunr search index...")
const index = await lunr.buildIndex([
`${__dirname}/content/post`,
`${__dirname}/content/fb`,
`${__dirname}/content/leren`])
await fsp.writeFile(`${__dirname}/static/js/redzuurdesem-post.json`, JSON.stringify(index), 'utf-8')
console.log("-- all done!")
})()

@ -6,17 +6,13 @@
"directories": {
"doc": "docs"
},
"dependencies": {},
"devDependencies": {
"@babel/cli": "^7.8.4",
"@babel/core": "^7.9.6",
"@babel/preset-env": "^7.9.6",
"lunr": "^2.3.6",
"parser-front-matter": "^1.6.4"
"@babel/preset-env": "^7.9.6"
},
"scripts": {
"build": "/usr/local/bin/hugo",
"install": "node build-lunr-index.js > static/js/redzuurdesem-post.json"
"jamstack": "node jamstack-init.js"
},
"repository": {
"type": "git",
@ -27,5 +23,8 @@
"bugs": {
"url": "https://github.com/wgroeneveld/redzuurdesem/issues"
},
"homepage": "https://github.com/wgroeneveld/redzuurdesem#readme"
"homepage": "https://github.com/wgroeneveld/redzuurdesem#readme",
"dependencies": {
"jam-my-stack": "^1.0.3"
}
}

File diff suppressed because one or more lines are too long

File diff suppressed because it is too large Load Diff
Loading…
Cancel
Save